Service Restored: Transaction Notifications and Name Enquiry (Nigeria)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting some of our Payment Processing Services has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Nov 17, 2025 - 11:58 UTC

Update

Please note that we have switched to our secondary rail and transactions are processing. We will keep you updated on the progress of this issue.

Affected Services:
Affected Markets: Nigeria
Posted Nov 17, 2025 - 10:00 UTC

Identified

Dear Valued Customer,

We are currently experiencing a service disruption impacting some of our Payment Processing Services. This issue is originating from a third party provider.

Customers may observe the following issues:
Delay in transaction notifications.
Failure of Name Enquiry requests.

Our technical team is diligently working with the provider towards a swift resolution.

We apologize for any inconvenience this may cause and will provide the next update as soon as we have more information.

Affected Services:
Affected Markets: Nigeria
Posted Nov 17, 2025 - 09:49 UTC
This incident affected: Flutterwave Collections (Collections APIs).