Service Restored: Collections Disruption on Rail Services in KENYA

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting some collections for our rail services in Kenya has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Nov 17, 2025 - 12:00 UTC

Identified

Dear Valued Customer,

We are aware of a service disruption impacting some collections for our rail services in Kenya. This is currently under investigation by our provider.

We apologize for any inconvenience. Thank you for your understanding. We will provide an update as soon as we have more information.

Affected Services:
Affected Markets: Kenya
Posted Nov 16, 2025 - 22:55 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).