Service Restored: Intermittent Transaction Notification Delays

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the issue impacting the speed and delivery of transaction notifications has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Nov 24, 2025 - 15:38 UTC

Identified

Dear Valued Customer,

We are currently investigating an issue impacting the speed and delivery of transaction notifications.

Customers may experience a delay in receiving confirmation alerts after completing a transaction.

This is being actively investigated by the technical team alongside our partner. We apologize for the inconvenience and appreciate your patience as we work to resolve this.

Affected Services:
Affected Markets: Nigeria
Posted Nov 24, 2025 - 12:07 UTC
This incident affected: Flutterwave Collections (Collections APIs).