[Rwanda] Service Restored: Mobile Money Transfer Delays

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the technical issues with a third-party provider in Rwanda which impacted transactions has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted Apr 22, 2026 - 18:48 UTC

Identified

Dear Valued Customer,

We are currently experiencing technical issues with a third-party provider in Rwanda. This is affecting both collections and payouts for some users. Our team is working with the service provider on a fix. Thank you for your patience and sorry for the inconvenience.

Affected Services:
Affected Markets: Rwanda
Posted Apr 21, 2026 - 16:42 UTC
This incident affected: Flutterwave Collections (Collections APIs).