Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 21:00 UTC
Scheduled
Dear Valued Customer,
We are conducting a proactive maintenance to upgrade a core component responsible for internal service communication. This activity is essential to prevent potential future issues related to service connectivity and stability. The activity typically takes 5–10 minutes. We anticipate minimal disruption, but users may experience brief, intermittent connectivity timeouts (less than 3 minutes) during the deployment window. We appreciate your understanding as we take this necessary step to ensure the continued reliability of our platform.
Posted Nov 25, 2025 - 16:31 UTC
This scheduled maintenance affected: Flutterwave Collections (Checkout JS, Collections APIs, Virtual Account Numbers, USSD Collections), Flutterwave Payouts (Payouts APIs), Flutterwave Offline (Point of Sale - POS, Agency App), Flutterwave for Business (Flutterwave Sign-up, Flutterwave API, Dashboard, Virtual Cards, Settlements, Chargebacks, Bill Payments (Airtime), Bill Payments (Cable TV)), Flutterwave Store (Merchant Stores), Remittance Products (SendApp, Swap, Tuition), Flutterwave Infrastructure (Windows Server Group), and Shared Services (Servman).