Service Restored: Intermittent Delays & Failures

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting our processing systems has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Global
Posted Nov 12, 2025 - 18:44 UTC

Identified

Dear Valued Customer,

We are experiencing a service disruption impacting our processing systems. This may lead to intermittent failures or delays across various transaction services.

Our engineering team is actively investigating the cause and working toward a resolution.

We apologize for any inconvenience this may cause and will update this page as soon as we have further information.

Affected Services:
Affected Markets: Global
Posted Nov 12, 2025 - 18:33 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).