Service Interruption Affecting Collections Rail

Incident Report for Flutterwave

Update

Dear Valued Customer,

We are still experiencing a low success rate on MONO rail. Work is still ongoing to resolve this. We will continue to share more updates as we learn more. We apologize for the inconveniences experienced, and we appreciate your patience.

Affected Services:
Affected Markets: Nigeria
Posted Nov 24, 2025 - 15:57 UTC

Identified

Dear Valued Customer,

We are currently observing a disruption impacting our Collections Processing Rail. This issue originates from a third party provider. Customers may experience delays or interruptions in collection activities.

Our partner is actively investigating the cause and working toward a resolution.

We apologize for the inconvenience and will provide the next update as soon as more information is available.

Affected Services:
Affected Markets: Nigeria
Posted Nov 16, 2025 - 19:42 UTC
This incident affects: Flutterwave Collections (Collections APIs).