Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 14, 2026 - 21:00 UTC
Scheduled
Dear Valued Merchant,
We will be performing a scheduled platform maintenance to enhance the reliability, scalability, and security of our payment infrastructure.
Expected Impact During the maintenance window, you may experience brief service interruptions or intermittent availability across our payment services. The following customer impacts may occur:
- Customers may be temporarily unable to complete some payment collections. - Payouts and withdrawals may be delayed or temporarily unavailable. - Some bank transfers, mobile money transactions, voucher payments, and QR code. payments may fail or remain pending until the maintenance is complete. - Cross-border payments and remittances may experience temporary delays. - Transactions initiated during this period may take longer than usual to be processed.
Any service disruptions are expected to be temporary as traffic is transitioned to the upgraded platform. Services will automatically resume once the maintenance has been completed.
We recommend scheduling any time-sensitive payment collections or payouts outside the maintenance window where possible.
Our team will actively monitor the maintenance activity and provide updates throughout the exercise.
Thank you for your patience and understanding as we continue to improve the reliability and performance of our platform.
Posted Jul 10, 2026 - 17:35 UTC
This scheduled maintenance affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).