InTouch (Moov), 10th September 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption affecting InTouch Moov has been resolved. All payout transactions are now processing normally.

We apologize for any inconvenience you may have experienced and thank you for your patience and understanding.

Affected Services:
Affected Markets: Ivory Coast
Posted Sep 10, 2025 - 18:38 UTC

Identified

Dear Valued Customer,

We would to inform you about a service disruption currently affecting InTouch Moov, which is impacting payout transactions on our system.

Our team is working with the provider to resolve this issue as quickly as possible, and we will provide an update as soon as we have more information.

We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding.

Affected Services:
Affected Markets: Ivory Coast
Posted Sep 10, 2025 - 18:11 UTC
This incident affected: Flutterwave Collections (Collections APIs).