Please be advised that we are still experiencing delays with merchant settlements. Our engineering team is actively working to resolve the issue and restore full services as quickly as possible.
We sincerely apologize for any inconvenience this may cause and will provide a further update as soon as more information becomes available. Thank you for your continued patience and understanding.
Affected Services: Affected Markets:
Posted Jun 03, 2026 - 12:33 UTC
Identified
Dear Valued Customer,
We are currently experiencing delays with merchant settlements due to a brief system issue. Our team is already working hard to clear the backlog and process your funds as quickly as possible. We are very sorry for the delay and appreciate your patience.
Affected Services: Affected Markets:
Posted May 29, 2026 - 07:52 UTC
This incident affects: Flutterwave for Business (Flutterwave API).