Service Restored: Pay with Bank Transfer (PWBT)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting pay with bank transfer functionality with one of our service providers in Nigeria has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Nov 13, 2025 - 00:23 UTC

Identified

Dear Valued Customer,

We are currently experiencing an unexpected service disruption impacting pay with bank transfer functionality with one of our service providers in Nigeria.

This issue is causing intermittent delays and failures for some customers. Our technical team is fully engaged and actively working with the provider to find the root cause.

We will provide an update as soon as we have a clear diagnosis or confirmation of resolution. We sincerely apologize for any inconvenience this may be causing.

Affected Services:
Affected Markets: Nigeria
Posted Nov 12, 2025 - 22:46 UTC
This incident affected: Flutterwave Collections (Collections APIs).