Service Restored: Uganda Mobile Money Collections

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

Please be informed that the reported downtime was due to a scheduled system maintenance. Transactions are processing fine now. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Nov 17, 2025 - 06:59 UTC

Identified

Dear Valued Customer,

We are aware of a service interruption affecting collections via mobile money service in Uganda.

This disruption is currently under active investigation by our service provider.

We understand this causes inconvenience and thank you for your patience while we work to resolve this issue with our provider.

Affected Services:
Affected Markets: Uganda
Posted Nov 16, 2025 - 22:52 UTC
This incident affected: Flutterwave Collections (Collections APIs).