Service Restored: Mobile Money Collections (Rwanda)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting payment collections in Rwanda has been successfully resolved. We are monitoring the situation closely to ensure continued stability. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted Dec 25, 2025 - 17:19 UTC

Identified

Dear Valued Customer,

We are aware of a service disruption impacting payment collections in Rwanda. We are working urgently to resolve this and will share updates shortly.

Thank you for your patience.

Affected Services:
Affected Markets: Rwanda
Posted Dec 25, 2025 - 16:07 UTC
This incident affected: Flutterwave Collections (Collections APIs).