Scheduled Maintenance, MTN CAMEROON, September 13 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the planned system upgrade on MTN Mobile Money, which took place from Saturday, 13th September 2025, at 07:00 PM UTC to Sunday, 14th September 2025, at 8:00 AM UTC, has been successfully completed.

All MTN MoMo services are now fully operational.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Cameroun
Posted Sep 14, 2025 - 13:05 UTC

Identified

Dear Valued Customer,

Please be informed about a system upgrade on MTN Mobile Money Cameroon.

Maintenance Schedule:
Start: Saturday, 13th September 2025, 07:00 PM UTC
End: Sunday, 14th September 2025, 8:00 AM UTC

During this time, you may experience interruptions on MTN MoMo services.

We apologize for any inconvenience this may cause and appreciate your understanding.

Affected Services:
Affected Markets: Cameroun
Posted Sep 13, 2025 - 07:01 UTC
This incident affected: Flutterwave Collections (Collections APIs).