Service Restored: Flutterwave for Business (F4B)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the delay in payout processing on our business application F4B has been successfully resolved. We are monitoring the situation closely to ensure continued stability. Thank you for your patience and understanding

Affected Services:
Affected Markets: Nigeria
Posted Nov 05, 2025 - 14:49 UTC

Identified

Dear Valued Customer,

We are currently experiencing a significant delay in payout processing on our business application F4B.

As a result, a high volume of recent payouts may be visible in NEW or PENDING status and are not yet being completed.

Our engineering team is actively engaged and working to restore normal processing speed as quickly as possible.

We apologize for the inconvenience and appreciate your patience.

Affected Services:
Affected Markets: Nigeria
Posted Nov 05, 2025 - 11:49 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).