Service Restored: Payment Collections (Rwanda)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the intermittent failures with our payment collection services in Rwanda has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted Jan 06, 2026 - 17:20 UTC

Identified

Dear Valued Customer,

We are currently experiencing intermittent failures with our payment collection services in Rwanda. Our technical team is working to resolve this as a priority. We apologize for the inconvenience and will provide an update shortly.

Affected Services:
Affected Markets: Rwanda
Posted Jan 06, 2026 - 13:59 UTC
This incident affected: Flutterwave Collections (Collections APIs).