Service Restored: Intermittent Transaction Failures

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting a subset of our payment processing in the US has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: US
Posted Nov 26, 2025 - 14:41 UTC

Identified

Dear Valued Customer,

We are currently experiencing a service disruption impacting a subset of our payment processing in the US. Transactions routed through a key external partner are experiencing timeouts and resulting in failures.

The provider responsible has been notified, and they are working on a resolution.

We apologize for any failed transactions and the inconvenience this causes. We will provide our next update as soon as new information is available from our partner.

Affected Services:
Affected Markets: US
Posted Nov 24, 2025 - 22:54 UTC
This incident affected: Flutterwave Collections (Collections APIs).