Service Restored: Intermittent Issue with Collections (South Africa)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the intermittent issue affecting our collection services in South Africa has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: South Africa
Posted Nov 11, 2025 - 07:09 UTC

Identified

Dear Valued Customer,

We are aware of an intermittent issue affecting our collection services in South Africa.

The disruption is originating from an external payment partner. We are seeing delays and failures in collections processing.

Our teams are engaged and awaiting confirmation of a resolution from the provider. We are sorry for the disruption and appreciate your understanding.

Affected Services:
Affected Markets: South Africa
Posted Nov 11, 2025 - 06:10 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).