Scheduled Maintenance, AIRTEL UGANDA, September 15, 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the maintenance on Airtel Uganda has been successfully completed. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Sep 15, 2025 - 11:07 UTC

Identified

Dear Valued Customer,

Please be informed about a system maintenance on Airtel Uganda Mobile Money Service.

Maintenance Schedule:
Start: Monday, September 15th, 2025, 10:00 PM UTC
End: Tuesday, September 16th, 2025, 02:00 AM UTC

During this time, you may experience interruptions on Airtel MoMo services.

We apologize for any inconvenience this may cause and appreciate your understanding.

Affected Services:
Affected Markets: Uganda
Posted Sep 14, 2025 - 20:12 UTC
This incident affected: Flutterwave Collections (Collections APIs).