Disruption to NGN Payouts, Sept 12, 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are happy to announce that the maintenance on the NIBSS payment platform has been completed. All NGN payout services have been fully restored and are now operating as normal.

We sincerely apologize for the inconvenience and frustration this recent disruption caused. We appreciate your patience and understanding.

Thank you for your continued trust.

Affected Services:
Affected Markets: Nigeria
Posted Sep 16, 2025 - 07:23 UTC

Investigating

Dear Valued Customer,

This is an important update regarding the ongoing disruption with our NGN payout services. We have received new information from our provider, that the issue stems from an unscheduled maintenance event on the NIBSS payment platform.

This maintenance is expected to be completed on Monday, September 15th, 2025, at 9:00 AM WAT.

We understand the frustration this extended outage may cause and sincerely apologize for the continued inconvenience. We are in constant communication with our provider and will restore all services the moment maintenance is completed.

We appreciate your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Sep 12, 2025 - 08:21 UTC

Identified

Dear Valued Customers,

We are currently experiencing a service disruption affecting NGN Payouts. This is due to a connectivity issue with our provider, NIBSS.

Our team is actively investigating the matter and working closely with the service provider to resolve it as quickly as possible. We will post another update as soon as we have more information.

We sincerely apologize for any inconvenience this may cause and thank you for your patience.

Affected Services:
Affected Markets: Nigeria
Posted Sep 12, 2025 - 07:02 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).