Intermittent timeout, NGN USSD SERVICE, Sept 16, 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the issue with NGN USSD payment service has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Sep 18, 2025 - 07:32 UTC

Investigating

Dear Valued Customer,

We are still experiencing an intermittent timeout with our USSD payment service. Our technical team has been working around the clock to resolve the issue, and we are making progress.

We understand this is frustrating and sincerely apologize for the continued inconvenience. We appreciate your patience and will provide another update as soon as we have more information.

Thank you for your understanding.

Affected Services:
Affected Markets: Nigeria
Posted Sep 16, 2025 - 14:34 UTC

Identified

Dear Valued Customer,

We are currently experiencing an intermittent timeout with our USSD payment service. This is affecting some collections. Our technical team is actively investigating the issue and working to restore full functionality as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience. We will provide another update as soon as we have more information.

Affected Services:
Affected Markets: Nigeria
Posted Sep 16, 2025 - 07:41 UTC
This incident affected: Flutterwave Collections (Collections APIs).